How to Change the Mail Sever and Port Settings on the iPad

I’ve received so many comments and emails regarding port and server settings on the iPad, that I figured I write a guide about it. Most of the time you don’t have to mess with these settings hence the reason it was not covered in the setup email account guide for the iPad, but because I’ve received so many requests, here it is. If you find that you need to enter specific server and port settings to configure your iPad’s email accounts follow the instructions below.

Software/Hardware used: iPad running iOS 4.2.

In order to demonstrate the following, I will be using a Gmail account I’ve set up on the iPad using the Exchange option. The same should apply to accounts that use Exchange and other email services. If you have any questions please use the comments form at the end of the guide.

1. Tap to open Settings from the Home screen.


2. Tap Mail, Contacts, Calendars in the Settings pane.

3. Tap on the account you wish to configure in the Accounts list.


4. When the account window appears, tap on Account (where the email address appears).


5. In the Account page you will find that there’s an Outgoing Mail Server section. This is where you have the option of setting the outgoing servers and changing the port settings (under Advanced).


A. When you tap on SMTP you will be able to Add Server or modify an existing server.


B. If you tap Advanced you will be able to set the Server Port and other advanced options.

I hope this guide helps those of you that had trouble finding these settings on the iPad. If you have any comments or questions please use the comments form below.

  • Angelisa

    i am getting no where, i have read everything, i have copied all the account info for my work emails from outlook to my ipad (all pop) and nothing is working excpet my comcast account, NO additional accounts will work period 🙁 i am leaving for vacation in a few hours and i had planned on taking my ipad, now i dont know what to do

  • B Van Meulenbroek

    Thnx but it doesn’t help: when setting up an account via ‘Other’ I don’t get to see the Advanced section prioir to saving the account. And saving the account without changing ports fails: configuration window hangs without returning or reporting an error.

    • This guide is specific to those accounts you have already set up….have you tried it with the account that has already been added regardless of the error?